Looking for answers
Ask a question

What are the iPhone device requirements for the app for Apple Watch?

The Apple Watch needs to be paired with an iPhone 5 or higher (5, 5C, 5S, 6, 6 plus or higher) running an iOS 8.2 or higher operating system.